Python

anyenvをインストール&Homebrewでインストール済のrbenvと互換を取る

rbenv 好きの [twitter:@riocampos] です。 pyenv も入れてます。 node.js はまだほとんど使ってないけど nodebrew だけぶち込んでいます。でも ndenv あると知ったのでそちらを入れたい、ついでに anyenv を入れよう、という魂胆です。 作者による anyenv …

anyenvをインストール2

anyenvをインストール&Homebrewでインストール済のrbenvと互換を取る - 別館 子子子子子子(ねこのここねこ) の続きです。 リンクを最低限にしたほうが対応しやすいはず さきほど書いた対応ではリンクを最低3つ張れば対応出来ます。でも、 **env 一つ当た…

anyenvをインストール3(gemの調子が悪くなった

anyenvをインストール2 - 別館 子子子子子子(ねこのここねこ) の続きです。 全ての gem に影響しているか今ひとつ分からなかったのですが、 gem 依存のあるスクリプトがうまく動かなくなりました。 rbenv-communal-gems プラグインを入れたあとの確認をほ…

homebrewを使うならばpyenvでは必ずPython2を一つ目に設定すること(もしくはPython3を優先したMacでのRicty作成苦労話)

結論 homebrewではpythonコマンドがPython 2であるとしてスクリプトが組んであります。 GitHub - Homebrew/legacy-homebrew: The former home of Homebrew/homebrew (deprecated) のでPython 3にすると、トラブルの原因になります。 対策1 タイトル通りに「…

pyenvインストール

pyenv Ruby使ってる人であれば「rbenvのPython版」で通じるかと。 つまり、Pythonの複数バージョンを切り替えれる環境をつくるものです。 今回はpyenvでPythonバージョンを変更したときに実行しないといけない「pyenv rehash」も自動で行ってくれる「pyenv-p…

MacでYoutube Liveストリーミングを保存するyoutube-dlスクリプト

youtube-dl Download videos from YouTube.com (and mores sites...) youtube-dl is a small command-line program to download videos from YouTube.com and a few more sites. It requires the Python interpreter (2.6, 2.7, or 3.3+), and it is not pla…

はてなグラフプッシュのプラン その2

ありがたいことにRubyで組んでくださった方が居られたのだが、アメダスデータを取りに行くページが主要観測点をまとめてあるところであったため、主要観測点の情報しかとれない。アメダスデータをいつも見ているのはこういうページ。 http://www.data.jma.go…

はてなグラフプッシュのプラン

はてなグラフ を自動的にアップデートさせたい。 まだ単なるメモ書き。 日付とその日の降水量・最高・最低・平均気温を気象庁から取得 はてなグラフへPOST。 はてなグラフapiとは - はてなキーワード pythonでWSSE認証。 参考: PythonでAtomクライアント - …